deepfacelab中文论坛

 找回密码
 立即注册
查看: 387|回复: 4

Me版本在Ubuntu系统下使用方法(仅供参考)

[复制链接]

3

主题

24

帖子

460

积分

初级丹师

Rank: 3Rank: 3

积分
460
QQ
 楼主| 发表于 2022-12-3 23:39:43 | 显示全部楼层 |阅读模式
星级打分
  • 1
  • 2
  • 3
  • 4
  • 5
平均分:5  参与人数:1  我的评分:未评
本帖最后由 我的心是冰冰的 于 2022-12-20 20:31 编辑

当然首先你得有Me版本:[url=【魔改增强版】DeepFaceLabMe_2022_RG_Ver2.55V2_(2022.9.16更新) https://dfldata.xyz/forum.php?mod=viewthread&tid=4902 (出处: deepfacelab中文论坛)]
解压完压缩包后你将得到一个完全可以在window上运行的me版DFL软件
首先,请先按照Me版本的教程先把补丁打好

接下来的步骤仅供参考,不一定具有普遍性,有问题欢迎留言我也积累积累经验
将下图DeepfacelabMe文件复制到Ubuntu系统下存放DFL源码的文件夹里
屏幕截图 2022-12-03 224138.png
复制完成后,你的Ubuntu系统DFL源码文件夹里应该有如下文件
屏幕截图 2022-12-03 230253.png
其实只要确保有DeepfacelabMe文件和scritps文件即可(如果你只用Me版本的话)
接下来就是配置环境了,环境和原版环境有一点区别,所需要的库软件版本参考Deepfacelab文件夹下的environment.ymlrequirements-cuda.txt文件,建议python用3.7版本
屏幕截图 2022-12-03 231315.png
值得注意的是opencv的版本,因为我的服务器是无图形界面的,所以用的是opencv-python-headless==4.4.0.46,之前按照上面的安装运行时会给我报“***cv2**"之类的错误。

环配置完成后,接下来就是修改scritps文件夹下的脚本文件了,首先修改env.sh文件,如下图所示
屏幕截图 2022-12-03 232248.png
其次,因为我只在Ubuntu系统上训练,所以只修改了6_train_SAEHD_no_preview.sh文件,下图是修改后6_train_SAEHD_no_preview.sh的文件与原bat文件对比,方便你们以后对比着改
我用的是无图形界面的服务器,所以加了--no preview,你们要是有图形界面的别加,不然没有预览
屏幕截图 2022-12-03 232614.png
基本就是这样,反正我是能用了,至于我用Me版本的原因是因为在原版训练的时候经常自动保存完后会卡住没反应,用来Me版本后好了不少,欢迎留言


=====================================
如果因为环境问题,我这边把环境打包了一下,你们先把包下载到/anaconda3/envs下,再使用tar命令解压就行


链接:https://pan.baidu.com/s/14KprUJRZYRPNLW_6VjdpWg?pwd=hxz3
提取码:hxz3

评分

参与人数 1威望 +1 收起 理由
lieyandatianshi + 1 不错值得给分

查看全部评分

回复

使用道具 举报

58

主题

433

帖子

2491

积分

初级丹圣

Rank: 8Rank: 8

积分
2491
发表于 2022-12-4 10:15:35 | 显示全部楼层
用me版比原版TensorFlow安装长几分钟时间,不知道为啥他要把全部版本呢TensorFlow都安装了,到2.7.4的
回复 支持 反对

使用道具 举报

3

主题

24

帖子

460

积分

初级丹师

Rank: 3Rank: 3

积分
460
QQ
 楼主| 发表于 2022-12-4 12:07:26 | 显示全部楼层
wwe456999 发表于 2022-12-4 10:15
用me版比原版TensorFlow安装长几分钟时间,不知道为啥他要把全部版本呢TensorFlow都安装了,到2.7.4的 ...

不是吧,使用pip install tensorflow-gpu 安装默认最新版本的
回复 支持 反对

使用道具 举报

58

主题

433

帖子

2491

积分

初级丹圣

Rank: 8Rank: 8

积分
2491
发表于 2022-12-4 12:46:38 | 显示全部楼层
我的心是冰冰的 发表于 2022-12-4 12:07
不是吧,使用pip install tensorflow-gpu 安装默认最新版本的

python -m pip install -r ./DeepFaceLab/requirements-cuda.txt
我用这个的
回复 支持 反对

使用道具 举报

3

主题

24

帖子

460

积分

初级丹师

Rank: 3Rank: 3

积分
460
QQ
 楼主| 发表于 2022-12-4 13:46:21 | 显示全部楼层
wwe456999 发表于 2022-12-4 12:46
python -m pip install -r ./DeepFaceLab/requirements-cuda.txt
我用这个的

可以,没什么问题,这样安装比较方便,直接就安装完了所有需要的库
回复 支持 反对

使用道具 举报

QQ|Archiver|手机版|小黑屋|deepfacelab中文论坛 |网站地图

GMT+8, 2023-1-30 11:55 , Processed in 0.051398 second(s), 38 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表